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1. Introduction

This manual describes the system requirements and the license activation process of the
Mix? software. In addition, command line options of the software are discussed as well as its

input and output format. For further questions related to the Mix* software please contact
bioinfo@lexogen.com.
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2. Requirements

The Mix? software runs on Linux x64 distributions. The graphical user interface of the Mix?
license manager requires GTK+ 2.6 or higher and the official PNG reference libraries (libpng
12.0). During operation the software will access port number 36963, which therefore has to
be free. There is no data flow via this port. It is used only for the synchronization of multiple
running instances of the software.

To run the Mix? software on a computer cluster, please contact us at bioinfo@lexogen.com.

The Mix? software has been tested on:

« Ubuntu 12.04+ Desktop x64
« Ubuntu 12.04 Server x64

» openSUSE 13.2 Desktop x64
» openSUSE 12 Server x64
 Linux Mint 17.1 Desktop x64
» Fedora Live 20 Desktop x64
« CentOS 7.0 Desktop x64

If you encounter any problems when running the Mix® software, please contact us at
bioinfo@lexogen.com.

'This port is normally used for “Counter Strike".
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3. Mix? License Manager

Prior to running the Mix’ software a license needs to be downloaded and activated via the
Mix? license manager. If the license is to be deployed in a global directory to allow access
for multiple users, then the license manager must be run with root privileges.

Mix-Square License Manager ]

Status: Invalid. Click the "Manage License" button to activate.

Check The License ManageLicense] [ Exit |

Figure 1. License Manager Main Window

4

Figure 1 shows the main window of the license manager. Clicking on the “Check The License”
button will check the validity of the license. The license can be downloaded and activated by
clicking on the “Manage License” button.

License Status

Name |5I:a|:us | ‘
License |9200:License not found - activationis required.

Actions
Iwant to... Using...
@ Activate a license or renewal. @ This computer's Internet connection.

Refresh my license () Another computer's Internet connection.

License Details :

Password : | |

Installation ID : | |

Installation Name : | | (Optional)

Cancel | Back Next |

Figure 2. License Activation Window
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Figure 2 shows the license activation window, which appears after clicking the “Manage Li-
cense” button in the main window of the license manager (Figure 1). The license manage-
ment window provides information regarding the license status and can be used to com-
plete the license activation process. A number of actions are defined in this window.

« Activate a license or renewal: This option is used to activate and download a license
using the License ID and Password obtained for a trial version or through purchase of the
software. Upon the activation request an Installation ID will be assigned to the system
on which the license is activated. Providing an installation name serves the purpose of
making licenses easily distinguishable and is optional.

» Refresh my license: This option is used to refresh a license status. If a license is extended,
the software will usually download the new license file automatically upon checking for
the license status. However, if the software fails to refresh the license automatically the
“Refresh my license” option can be used to manually request a license refresh.

« Deactivate this workstation: This option allows to deactivate a license on a workstation
and to activate this license instead on another workstation. The number of reactivations
on different workstations is limited depending on the type of license.

» This computer’s internet connection: This option activates and downloads the license
using the internet connection of the computer on which the license manager is running.

« Another computer’s Internet connection: If the computer, on which the license is to
be installed, does not have Internet connection, then the license can be downloaded
through another computer’s connection. The option “Another computer’s Internet con-
nection” option is used to generate the XML license request file. The XML request file
then needs to be uploaded to the license server manual response page ( https://secure.
lexogen.com/solo/customers/ManualRequest.aspx ) and an XML response file has to be
downloaded. The latter is then used to create the license file for the computer without
Internet connection.

If the Mix? software is to be run on a computer without window manager, e.g. a typical
server, the graphical user interface of the Mix” license manager can be exported to another
machine with window manager. This is achieved by logging into the computer without win-
dow manager from the computer with window manager with ssh using the —X switch and

subsequent execution of the license manager on the remote machine.
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4. Running Mix?

The Mix? software can be run from the command line as follows:
/mix-square [options] <arguments>

Options

General Options:

-h[—help]
-G[--GTF]arg
-B[--BAM ] arg

-0 [--output-dir] arg

-p [--threads] arg

Describe options.

Directory of the reference annotation file. Please refer at Mix * Input section.
Directory of the RNA-Seq read alignments in BAM format. SAM file format is not sup-
ported. The alignments need to be sorted by their leftmost coordinates.

Sets the output directory which the results will be saved to. The default is a directory
called “output”in the current working directory. If the path to output-dir is relative it
will be generated within the current working directory.

Number of threads to be used for the estimation process. The max number of

threads can be used depends on the license type. Please note that this option is not
available for trial & free licenses.

Clustering Options:
-R [—results-dir] arg
-n [--nr-clusters ] arg

--min-trans-len arg

—min-trans-frags arg

Directory which contains mix-square run results.

Maximum number of clusters to be produced. Default: 5

Transcripts shorter than minimum transcript length are excluded from the clustering
process. Default: 200bp

Transcripts which has less fragments than min-trans-frags are excluded from the
clustering process. Default: 100

Advanced Abundance Estimation Options:

-x [ --max-total-frags ] arg

-M [--max-comp-frags ] arg

-m [--min-comp-frags ] arg

-q [ --min-param-diff] arg

-i [ --nr-iterations ] arg

-T [ --likelihood-threshold] arg

8 LEXOGEN - Mix? User Guide

Sets the maximum number of fragments in a locus. A locus which has more frag-
ments than the maximum number is skipped. Genes skipped can be found in
genes_skipped.list. Default: 5000000

Sets the maximum number of valid fragments in a locus. A locus which has more
valid fragments than the maximum number is skipped. Genes skipped can be found
in genes_skipped.list. Default: 5000000

Sets the minimum number of valid fragments in a locus. A locus with less valid
fragments than the minimum number is skipped. Genes skipped can be found in
genes_skipped.list. Default: 1

Sets the minimum parameter difference between 2 iterations. Default: 1e-5

If the minimum Log Likelihood condition is not reached then the EM algorithm will
terminate if the maximum number of iterations is reached. Default: 500

Sets the minimum log likelihood difference between 2 iterations. If the log likeli-
hood difference between two iterations is below this value, then the EM algorithm
terminates. Default: 0.5



-L [--genes-list] arg
-b [--blocks ] arg

-e [-exclude-genes ]

-t [--global-tying ]

-1 [-log-files ]

Afile containing gene IDs which are included or excluded in the experiment.

This number defines how many mixture components are used to model the bias of
fragment startsites. This number can be understood as the 'resolution’ of the pdf.
Accepted values are natural numbers from 1 to 10. The default is 3.

With this option, mix-square model excludes the genes which are specified in the
genes list file via the -L option.

With this option, global tying is turned on which means that all the isoforms of a
gene share the same parameters for the fragment start distributions This options
should only be used if the relative fragment start distributions of the isoforms within

a gene can be expected to have a similar shape, or in case of data sparsity.

Turns on estimation process logging. An individual file is created for each gene.

Advanced Program Behavior Options:

-s [ -license-status ]

-r [—-ignore]

-d [--debug]

With this option, you can view some information related to your license.

With this option, the warnings, which may be shown while using the max-frags-
locus option, are turned off.

This option turns on the debugging mode. This should only be used to obtain diag-
nostic information when facing problems with mix-square.
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5. Mix? Input

GTF (gene transfer) format and a file which contains the alignments in BAM (binary SAM)
format.

The structure of the annotation file should be like:
<segname> <feature> <start> <end> <strand> [attributes]

seqname The name of the sequence. Chromosome ID or contig ID.

o,

2 feature Exon Record type which can be “CDS’, “start codon’, “stop codon’,

o,

exon’,

",

“intron’, transcript” etc. All the record types are igno-

red except “exon”.

3 start 51456206  Start coordinate of the feature, in this case the start coordinate
of the exon.

4 end 51456321 End coordinate of the feature, in this case the end coordinate
of the exon.

5 strand + The strand which exon comes from. Should be “-* or “+".

Attribute Attribute Description

number name

gene_id ENSG00000167754 A globally unique identifier for the genomic locus of
the transcript.

2 transcript_id ENST00000391809 A globally unique identifier for the transcript.

3 gene_name KLK5 The name of the gene.

4 end 51456321 End coordinate of the feature, in this case the end

coordinate of the exon.
If one of the above fields/attributes is missing, the entry is skipped.

If an experiment needed to be done on a specific list of genes, then -L option could
be used. That option expects a file which includes the gene IDs (one gene ID per line).
A typical list should be as below:

ENSG00000167754

ENSG00000187999

ENSG00000123437

ENSG00000145310

Optionally, the -e flag can be used to exclude the genes specified in the genes-list.
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6. Mix? Output

6.1. BAM Index File

Mix? will produce an index file for the input BAM file if no such index file is present.

6.2. Genes_summary file

Field | Field name

num-

ber

1 gene_ID

2 gene_name

3 locus

4 frags_locus

5 frags_expt

6 FPKM_THN

7 comp_frags_locus
8 comp_frags_expt
9 FPKM_CHN

10 status

ENSG00000167754

KLK5

19:51446559-
51456349

20000
200000000
452420.36

10000

100000000

904840.73

OK

Description

A globally unique identifier for the genomic locus
of the transcript.

The name of the gene.

The locus which the gene is referenced to. Chromo-
some ID:start coordinate - end coordinate.

Number of fragments in the specified locus.
Total number of fragments in the experiment.

FPKM total hits norm. FPKM_THN is calculated
counting all fragments including those which
are not compatible with any reference transcript.
FPKM_THN is calculated continuously during the
experiment.

Number of fragments in the specified locus,
which are compatible with a reference transcript.
comp_frags_locus should be used to calculate
isoform row counts for differential expression
analysis. comp_frags_locus should be used to
calculate isoform row counts for differential
expression analysis.

Total number of fragments in the experiment,
which are compatible with a reference transcript.

FPKM compatible hits norm. FPKM_CHN is
calculated counting only the fragments, which are
compatible with a reference transcript. FPKM_CHN
is calculated at the end of the experiment. FPKM_
CHN should be used for differential expression
analysis.

Whether the estimation process was successful
or not.
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6.3. Transcripts_summary file

10

11

12

13

14

15

16

12

Field name

tracking_ID

gene_ID

gene_name

locus

length
fragment_validity_coverage
abundance

frags_locus

frags_expt

FPKM_THN

comp_frags_locus

comp_frags_expt

FPKM_CHN

nr_mixture_comp

mean_N

beta_N

LEXOGEN - Mix? User Guide

ENST00000391809

ENSG00000167754

KLK5

19:51446559-
51456349

1405

0.93
0.23416
20000
200000000
452420.36

10000

100000000

904840.73

376

0.359

Description

A unique identifier for the transcript.

A globally unique identifier for the genomic locus
of the transcript.

The name of the gene.

The locus which the gene is referenced to. Chromo-
some ID:start coordinate - end coordinate.
Transcript length in basepairs.

Validity coverage for the specified transcript.
Estimated relative abundance.

Number of fragments in the specified locus.

Total number of fragments in the experiment.
FPKM total hits norm. FPKM_THN is calculated
counting all fragments including those, which

are not compatible with any reference transcript.
FPKM_THN is calculated continuously during the
experiment.

Number of fragments in the specified locus, which
are compatible with a reference transcript.

Total number of fragments in the experiment,
which are compatible with a reference transcript.
FPKM compatible hits norm. FPKM_CHN is
calculated counting only the fragments, which are
compatible with a reference transcript. FPKM_CHN
is calculated at the end of the experiment.
Number of the mixture components used in the
experiment.

These values are used for recalculation of the esti-
mated fragment distributions for later use with the
clustering algorithm.

These values are used for recalculation of the esti-
mated fragment distributions for later use with the
clustering algorithm.



/. Investigation of the Positional Bias

The Mix* software makes no assumptions about the coverage bias, but fits a mixture model
to the data for each gene isoform. Therefore, the Mix* software can be used to investigate
the positional bias. Once the quantification of the RNA Seq data is done by the Mix?, then the
clustering procedure can be started. The Mix’ software recalculates the estimated fragment
coverage distributions from the Mix? transcript expression results and sub-sequentially runs
a hierarchical clustering algorithm to cluster the data.

The Mix® clustering procedure can basically be started as follows:
e /mix-square -R /home/user/mix2_results_dir/-n 8

This command uses the transcripts_summary.dat file in mix2_results_dir directory to recal-
culate the estimated fragment distribution for each transcript and then runs a hierarchi-
cal clustering algorithm to classify these distributions limiting to a maximum number of 8
clusters. The clustering procedure creates two additional files in the results directory. Those
files are called “norm_pdfs”and “norm_pdfs.clusters”. The former includes the normalized es-
timated fragment coverage distributions, whereas the latter includes the clusters detected
by the clustering algorithm. These files can easily be used to visualize the results with some
other techniques such as in R. However, the Bias Investigator tool, developed by Lexogen as
an addition to the Mix? software, can be used for that purpose.

Start by running the Bias Investigator tool by double clicking to Bias Investigator.jar file lo-
cated under mix-square directory. Make sure that the .jar file is executable. You can do that
by right clicking to the jar file, go to permissions and select Allow executing file as program
on Linux distributions or you can do that in the terminal by running “chmod 750 Bias Inves-
tigator.jar”.

You should start by importing the clustering data. The data can be imported from File >
Import menu. A folder that contains the results of a single experiment or a folder that con-
tains multiple folders containing different experiments can be imported. Figure 3 shows a
folder that contains N experiments. “Experiments” folder or a single experiment folder such
“Experiment 1” can be selected.
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genes_summary.dat

genes_summary.dat

transcripts_summary.dat transcripts_summary.dat

norm_pdfs.clusters norm_pdfs.clusters

Figure 3. Experiments folders view

If a folder that contains multiple experiments is selected, then the Bias Investigator tool
merges all the clusters within an experiment and shows the overall distribution. Each of
this plots representing a single experiment can be double clicked to show the underlying
clusters.

In single experiment mode, when a folder containing a single experiment is selected, the
Bias Investigator tool shows the median, 5% and 95% quantiles rather than the estimat-
ed distribution of each transcript. Figure 4 shows a single experiment view with 4 clusters
which were detected. The X axis in these plots is the transcript length normalized to 100 bps
and the Y axis is the normalized estimated fragment distributions.
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File Edit Help

Cluster 1 - 20.88% Cluster 2 - 15.62%

20 30 40 50 60 70 o 20 30 a0 50 60 70

Normalized Transcript Length - Avg: 2014 Normalized Transcript Length - Avg: 740

Cluster 3 - 39.78% Cluster 4 - 23.46%

Normalized Est. Coverage
°

30 40 50 60 70 80 90 10 20 20 40 50 50 70 100
Normalized Transcript Length - Avg: 653 Normalized Transcript Length - Avg: 2130

Figure 4. Clusters detected for a single experiment

The clustering algorithm sometimes may not merge two similar clusters successfully due to
its sensitivity. In such cases the clusters can be merged manually. The clusters can be merged
by holding “shift” button and selecting the clusters to be merged by mouse-left click. The
clusters which are selected are highlighted with a green border layout as shown in figure
4 the cluster 2 and cluster 3 have similar distributions as well as average transcript length.
Once the clusters are selected, the merging process can be done via Edit > Merge or by
using the shortcut (ctaL J+(1). The new cluster will have the smallest figure ID among the
selected ones. Table 1 shows the actions can be taken in Bias Investigator tool.
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Cluster 4 - 23.46%

Normalized Est. Coverage

35 40 a5 50 55 60 65
Normalized Transcript Length - Avg: 2130

Figure 5. Estimated distributions in cluster 4

Table 1. Bias Investigator shortcuts

Imports the clustering data File = Import +®
Saves the current view File > Save As + @
Merges selected clusters Edit > Merge +@
Undo last merging activity Edit > Undo +@
Merges all clusters Edit > Merge All + @
Demerges all clusters Edit > Demerge All +@
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8. Test Case

The distribution of the Mix? software contains a small test set of artificial data, which enables
the user to try out the basic functionality of the software. The example directory contains a
GTF file for gene KLK5 and a sorted BAM file.

Here are two examples for how Mix* can be run from the command line on the test data:
e ./mix-square -G example/KLK5.gtf -B example/KLK5.sorted.bam
- In order to run Mix* the above parameters are required at least. Since no output
directory is specified, the results are saved in the current working directory under a
directory called output.

 ./mix-square -G example/KLK5.gtf -B example/KLK5.sorted.bam -b 3 -t -o test-example-
data
- In this example the output directory has been specified as well as the number of
blocks. In addition, the global tying option has been switched on, which means that
the fragment start distributions of all isoforms within a gene share the same set of
parameters.

o ./mix-square -R /home/user/mix2_results_dir/ -n 5 --min-trans-len 250 --min-trans-frags
50
- This command starts the clustering procedure. The clustering algorithm restricts the
numbers of the clusters to 5 and filters out the transcripts which are shorter than
250bp as well as the transcripts which have less fragments than 50.
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9. Notes
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